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1. Introduction 

1.1 Brief description of WinPLC7 

The WinPLC7 software is a programming and simulation system for SIMATIC®-S7 type S7-300®, 
S7-400® and ADAM 811x, ADAM 821x  PLCs and compatibles.. 
 
The programmer can create STEP®7 programs on a PC in STL, FDB and LAD. Completed 
programs can be tested in off-line mode on the PC and without any hardware. 
The software-PLC integrated into WinPLC7 operates exactly like a real S7-PLC. The software-PLC 
can be used to analyse incorrect responses and to use the diagnostic options by means of the 
diagnostic buffer, USTACK and BSTACK. 
 
You can use an MPI cable to transfer the S7 program into a real PLC. This connection also 
supports high data transfer rates of 57600 and 115200 baud. 
 
For the connection to ADAM-CPUs you can also use the Green-Cable (at 38400 baud). The 
Green-Cable can only be used with ADAM CPUs! 
 
The program provides cannot be used for the SIEMENS S7-200 since this PLC does not accept 
programs created in the STEP®7 programming language. Furthermore, the hardware protocols 
are different from those that are used by the S7-300®/400. 
 
 
 

 

1.2 System requirements 

•Pentium at 233 MHz and 64MB of RAM 
•A display adapter providing a min. of 16-bit colours 
•Win 98 SE, WinME, Windows 2000, Windows XP 
•MPI cable to communicate with an S7-PLC of the series S7-300®, S7-400® , MHJ-
Netlink via TCP/IP or a "Green-cable" for ADAM-CPUs. 

 
We recommend a minimum resolution of 1024 x 768 pixels. 
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1.3 Installation of WinPLC7 

You need the following things to activate WinPLC7: 
 

•A demo version of WinPLC7/WIN PLC7 (at least version 2.23). 
*** Important: It is at least version 2.23 necessary ***  
•A serial number (35 digit) of WinPLC7. 
You have got the serial number at the purchase of the software.  
•An internet connection and a valid mail address. 

   
Installation of WinPLC7 / WIN PLC7 
 

1. Install the demo version  
2. Open the example-project with menu item File->Open/Create a project  
3. Choose the menu item "Extras->Others->Enable program functions".  
4. Type in "enable" as password.  
5. It appears the dialog "Activating program". 

- The SYS number is displayed in the second field. 
- Press the button "Copy into clipboard", which is right of the field.  

6. Establish a connection to the internet.  
7. Visit the site: www.WinPLC7.com/enable/F_GetKeyForm.HTM  
8. Click with the mouse to the field "System number" and then press CTRL+V to insert 

the system number.  
9. Type in the serial number (35-digit) into the field "serial number". 

If you have stored the serial number in a file, you should insert the number via copy 
and paste to avoid writing mistakes.  

10. Type in your email address into the field email address.  
11. Type in your name into the field "Your name"  

 
After you filled out all fields press the button "Send". 
A valid activation key will be sent to the given email address. 
 
After you received the activation key, open the dialog "Activating program" again (see 5.) 
Insert the activation key into the third field. Insert the serial number into the first field. 
Press the button "OK". 
Close the program and open it again. Then the software is activated. 
 
Note: 
You can request an activation code over this form up to 10 times. 
Please, don't pass the serial number on. Otherwise you can request no more activation code. 
 
If you have further questions to this process, send an email to:  info@WinPLC7.com. 
You can write in German or English language. 
 
 
.
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2 Introduction and brief tutorial 
This chapter contains a number of different brief tutorials that provide you with a quick introduction 
to the WinPLC7 program. 
 

2.1 The arrangement of the WinPLC7 screen 

 
 
(1) Mouse-bar for frequently used functions. 
(2) Project navigator providing access to the most important windows.  
(3) Block editor to change OB/FC/FB/DB 
(4) Symbolism editor to create symbolism files. 
(5) PLC-mask simulation 
(6) Command list for STL/FDB/LAD 
(7) Status indicators of the PLC/simulator 
(8) Status bar 
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2.2 Opening a WinPLC7 V2 project 

Select menu item "File->Open/create a project" to open an existing project.   
The following dialog box is displayed: 
 

 
 

Open/create a project dialog box 
 
This dialog box displays all the projects that exist in the selected project directory. The default 
location of the directory is the installation directory of WinPLC7. You can change the project 
directory by means of the "..." button located next to the directory line. 
You can open an existing project by selecting the respective project from the list of "Available 
projects" followed by the "Open" button. 
As a result the opened project is displayed in the title of the window. 
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2.2.1 Opening a sub-project 

A single WinPLC7 project can contain several sub-projects. You can open the required sub-project 
by selecting the menu item "View->Sub-projects". You can also access this dialog box by means of 
the project navigator. You must use the following button for this purpose. 
 

 
 

Fig.: accessing the sub-project dialog box  
by means of the project navigator 

 
The sub-project dialog box is displayed as follows: 
 

 
 
Every sub-project contains a PLC program. To open a sub-project you select the sub-project in the 
list and press the "Open" button.   
   
Only 1 sub-project can be active when you are working WinPLC7. The commands in menu item 
"PLC" always refer to the active sub-project. 
 

2.2.2 Opening blocks in a sub-project 

The blocks contained in the sub-project that is currently open are displayed in the "Block 
management" dialog box. You can access this dialog box via the menu item "View->Block 
management". You can also use the following button on the project navigator for this purpose. 
 

 
Fig.: Accessing the "Block management"  

dialog box via the project navigator 
 

Select the required block in the "Block management" dialog box and press the "Open" button. The 
selected block is displayed on the desktop. 
 
Note: 
A list of the 9 recently used projects will be displayed in menu item "View->Re-open". You can use 
keys '1' to '9' to open these projects quickly... 
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2.3 Creating a new project 

To create a new project you must first select menu item "File->Open/create a project". The 
following dialog box is displayed: 

 
 

Fig.: Open/create a project dialog box 
 
This dialog box displays all the projects that exist in the selected project directory. The default 
location of the directory is the installation directory of WinPLC7. You can change the project 
directory by means of the"..." button located next the directory. 
A new project will be created in the specified project directory. The advantage of saving all the 
projects in a single directory is you will only have to backup the respective directory when you 
create the necessary backup.   
   
Press the "New project" button to enter the name for the new project. Type the name into the input 
dialog box that will be displayed. 
 

 
 

Fig.: entering the name for the new project. 
 
The project is created when you confirm your entries by pressing "OK".  
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2.3.1Renaming a sub-project 

When you create a new project a sub-project with the name of the project is created in the project 
by default.   
You can change the name of this sub-project by means of the "Manage sub-projects" dialog box.   
Access to this dialog box is provided by the menu item "View->Sub-projects". You can also press 
the following button on the project navigator. 
 

 
 

Fig.: accessing the sub-project dialog box  
via the project navigator 

The resulting dialog box is displayed as follows: 
 

 
 

Fig.: sub-project dialog box 
 
To rename a sub-project you must select the respective entry in the list and press the "Rename" 
button. Enter the required name into the dialog box that is displayed. 
 

 
 

Fig.: entering the new name into the dialog box. 
 
 
When you have confirmed your entry by pressing "OK" the renamed project is entered into the list. 
Press the "Open" button to open the sub-project. 
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Fig.: after renaming the sub project 
 
 
 
 
 
 
 
 

2.3.2 Creating a new block 

You can create a new block by selecting the menu item "File->Create a new block". You can then 
enter the name for the new block (e.g. FC10, FB1, DB3 etc) into the dialog box that will be 
displayed. The name must not exist in the sub-project.   
When you confirm your entry the editor of the respective block is displayed on the desktop. 

 

2.4 Procedure: creating an S7 Program 

The following steps are required to create a new S7 Program using WinPLC7: 
 

1. Open a new project using "File->Open/create a project" 
2. Display the sub-project dialog box by means of  "View->Sub-projects". Here you can 

rename and open the sub-project. 
3. Open the symbolism editor using "View->Symbolic editor". 

Enter the required symbols into the symbolism editor (symbol, operand, data type and 
commentary) 
Save the symbolism file by means of the button "Save". The symbols are now available to 
the project. 

4. Adjust the symbolism settings as required (menu item Extras->Settings->Symbolic 
settings).  

5. Create the required blocks by means of "File->Create a new block". 
 
Step 3 and 4 are only required if you wish to use symbols. 
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2.5 Simulating an S7-program 

The following steps are required to simulate an S7 program: 
 
1. Open a project 
First you open a project using "File->Open/create a project" 
 
2. Open a sub-project 
Display the available sub-projects by means of "View->Sub-projects". Select the sub-project in 
the dialog box and press the "Open" button. 
 
Note: 
When you open a project, the same sub-project is activated that was active when this project was 
closed.   
Step 2 is only required when you want to change the sub-project. 
 
3. Selecting simulator mode 
The list of mouse buttons contains a selection list where you can select the WinPLC7 simulator 
mode. Here you must select "Simulator". 
 

 
OB 

Fig.: WinPLC7 will use the internal software-PLC 
when you have selected "Simulator". 

 
4. Transferring blocks into the simulator 

At this point you must transfer the respective project blocks into the simulator. Select menu item 
"PLC->Send blocks". 

 
Fig.: selecting blocks for the transfer 
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Select the blocks you wish to send in the dialog box that is displayed and press the "Send" button. 
 
You can monitor the transfer in the "Log" tab of the dialog box. Here you can check whether the 
different blocks are transferred properly: 
 
 

 
 

Fig.: the log that is displayed after the transfer 
 
6. Setting the software-PLC to RUN mode 
The blocks will be processed as soon as the software-PLC is switched to RUN mode. For this 
purpose you select the menu item "PLC->Operating mode". A dialog box will be displayed where  
you must select the startup type "Hot restart" or "Warm restart". As a result, the shape of the  
function selector at the lower right edge of the WinPLC7 window will change. 
 

 
Fig.: function selector 
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7. Display the process-image windows 
Amongst others, you can use the process-image windows to switch the inputs in the simulation. If 
you wish to display these inputs you can select the menu item 
"View->View Process-image window". The respective windows are displayed as follows: 
 

 
Fig.: process-image windows 

 
You can dock the process-image windows to the upper portion of the desktop of WinPLC7.  
You can define the status of the operands on the display by double-clicking the address of one of 
the process-image windows (for instance PEB0 in the figure above). The dialog box "Process-
image-line configuration" will be displayed. 
 

 
Fig.: the dialog box to configure the process-image window 

 
In this dialogue you can select the operands that must be displayed and the respective format. You 
can change the status of input bytes and flag bytes in order to simulate the PLC program. The 
settings are accepted when you press "OK" 
 
. 
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8. Displaying the block status 
Select the menu item "Block->Monitoring On/Off" to view the status of a block. The result is that 
the OB1 of the software-PLC and the status of the different lines are displayed. 
If you wish to display another block in the CPU right-click the editor of OB1. A Context menu will 
be displayed where you can select the menu item "Open block". The result is that the dialog box 
"Change block (PLC)" is displayed. 
 

 
Fig.: "Change block (PLC)" dialog box 

 
This dialog box lists the entire block that is available in the CPU (in this case those that are 
available in the software-PLC). You can now select the block of which you wish to view the block-
status. The status window can be displayed as follows: 
 

 
Fig.: the "Block status" window 
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2.6 Importing an S7-program from STEP®7 of SIEMENS 

It is possible to import a project that was created by the SIEMENS-STEP®7 software (version 4, 5 
or higher) into WinPLC7 by means of the menu item "File->Import->S7 Project (S7P). 
 
Procedure: 
 

1. If you have not done so, open or create a project (File->Open/create a project). 
2. Create a new sub-project using the dialog "Manage sub-projects" (View->Sub-projects) 
3. Select the menu item "File->Import->Import S7P" 

4. A selection-dialogue will be displayed. Use the dialog to locate the STEP®7-project that 
you want to import. Select a STEP®7-project file that has the extension .S7P: 
Press the "OK" button when you have selected the file. 
 

 
 

5. The selection dialog shown below will be displayed: 
 

 

 
Select the required S7 program and press the button "OK". 
 

6. A block selection dialog box will be displayed where you can select the blocks that you wish 
to import. You confirm your entries by means of the  "Import" button. 
 

7. The selected blocks are imported and you can edit them by means of WinPLC7. 
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2.7  Exporting an S7-program for STEP®7 of SIEMENS 

You can use the menu item "File->Export...->Export S7P"   
to export a WinPLC7 project in the project-format of the original SIEMENS software. 
The following data is exported: 

 
•Blocks OB, FC, SFC, FB, SFB, DB 
This export includes the protected blocks. 
•All commentaries  
(block commentaries, network commentaries, block titles, ...) 
•Symbolism file 

 
The STEP®7 project-format consists of several tables and many different files.   
The exported project is always stored in "S7P" directory in the current sub-project directory.   
When the export has been completed you should archive the project using "ZIP" or "ARJ" to 
simplify transportation. 
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2.8  Interfacing with an ADAM 811x, ADAM 821x 

The following procedure is required to establish a connection with an S7-300®/S7-400® or 
compatible controller: 
 

1. Open a project using "File->Open/create a project". 
2. Open a sub-project by means of the "Manage sub-projects" dialog box. Select menu item 

"View->Sub-projects" for this purpose. In the list of communication paths you must select 
"External RS232" 

3.  

 
 

Fig.: when you have selected "External RS232"   
4. WinPLC7 is using an external S7-PLC. 

 
5. Enter the interface data by means of the menu item "Tools->RS-232 interface settings". 

For instance: 
- Baud rate 
- COM-port 
Press the button "Direct". This establishes a connection with the PLC that is connected 
directly to WinPLC7.You require an MPI cable that is connected to the serial interface of the 
PC to be able to establish a connection. Exception: for ADAM-CPUs you can use the so-
called Green-Cable. In this case the baud rate must be set to 38400. 

6. Press the button "Establish a test connection". The message "Connection OK" should be 
displayed. 

7. If you should encounter errors check the following: 
- correct COM-port (COM1 ...COM4) selected? 
- correct baud rate selected in WinPLC7? 
- correct baud rate selected on the MPI-cable? 

8. When the connection has been established successfully you can use the functions in the 
"PLC" menu tree (e.g. Module status) 
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3 Additional information 
You can obtain additional information about WinPLC7 from the following sources: 
 

•The online-help of WinPLC7 menu item "Help->Help contents" 

 
 
 
 


